Follow us on...
Follow us on Twitter Follow us on Facebook Watch us on YouTube
Results 1 to 2 of 2
  1. #1
    Join Date
    Last Online

    03.29.16 @ 07:47 AM
    Liked 84 Times in 55 Posts

    Default Original 5150 head - What tubes you all use?

    I have an original 5150 head, the chip board manufacturing date is in January 1991. I have been playing for almost 17 years but technically not the smartest when it comes down to electronics or tubes. Anyways I know this puppy can get alot more growl out of it, than I am hearing. I originally was using Sovtek 6l6s, and Mesa II (Russian...) 12x7s, I mixed up the 12x7's with a cheap JJ type and still didn't like it, I got Ruby GLCMSTRS or whatever they are 6l6s, and it even had less bite than the Sovteks. I finally tried Groove Tube 6l6s, and newer Mesa 12x7s and so far have gotten the best sound out of all those combinations thus far, but still I know it can sound a lot better, there are so many gosh darn tube brands I have no idea let alone the V1, V2, or what a phase inverter tube does I have no clue... And Eddie uses Phillips tubes or did at one point? What the heck...

    I am pretty certain as well the head has not been properly looked at or serviced not once. I took it out of the cab box, cleaned it and to me the electronics look mint and everything is connected properly. But I have no idea if the two big heavy capacitor boxes have something in there that needs to be looked at? No clue. I am getting a lot of white noise (and no it is not because of my outlet or other electronics or background stuff plugged in or running...), even using two different noise gates, and also have a bizarre problem where sometimes when my effects loop is engaged, the output of volume, distortion and overall power is lower than it was without it engaged. If I do not use the foot pedal, and have the loop hooked up, it just runs at that lower output power at all times.

    Anyways you have no idea how many people I have messaged on youtube vids, even the Peavey forum itself, and no one can really give me a straight answer about tube ideas or this fix, they always suggest oh email this person at this website and buy their tube packages or all this nonsense. Us felllow VH and 5150 fans have to stick together please help me!!!

  2. #2
    Good Enough evhintexas's Avatar
    Join Date
    Favorite VH Album

    Fair Warning
    Favorite VH Song

    Push comes to shove
    Last Online

    10.27.16 @ 07:44 AM
    Liked 853 Times in 527 Posts

    Premium Member



    I believe the power tubes where Chinese 6L6GC. That is about all I remember.
    Last edited by evhintexas; 05.13.15 at 04:30 AM.
    "The tree of liberty must be refreshed from time to time with the blood of patriots and tyrants."

    A patriot must always be ready to defend his country against his government.



Similar Threads

  1. Original Block Letter 5150 Power Tubes
    By we die young in forum Guitar Room
    Replies: 12
    Last Post: 03.09.11, 01:07 PM
  2. Original Blockletter 5150 Preamp tubes
    By we die young in forum Guitar Room
    Replies: 12
    Last Post: 03.04.11, 09:56 AM
  3. ZAKK WYLDE with EVH's original Marshall amp head
    By ED-A-HOLIC in forum Main VH Discussion
    Replies: 30
    Last Post: 08.15.10, 07:50 PM
  4. 5150 Amp Help! (Original Block Letter Head)
    By bangerang5150 in forum Guitar Room
    Replies: 2
    Last Post: 07.20.07, 06:59 PM
  5. Replies: 6
    Last Post: 01.19.05, 09:06 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts